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Substantial 2D Drawing Speed 
Improvements 

 

Introduced In Alibre Design 7.x 

Boolean operations 
Part and Assembly booleans allow you to combine multiple parts together, subtract one part's geometry from 
another's, or find the intersection of two parts. Especially useful for the design of moulds and dies. 
 

Access to standard Windows file system 
You are no longer required to use the Repository to store data. Standard Windows File System support is available. 

 



Subassembly Motion 
You can set the "Make Flexible" flag for subassemblies to allow them to move and articulate normally. Previously, 
subassemblies could not display normal assembly motion. 

 
Faster Drawing Loading and View Creation 

"Light Drawings" substantially decrease the time it takes to load an existing drawing or project new views. 

 
Multiple drawing sheets  

You can now have multiple drawing sheets in the same drawing file. 

 
Export drawings and 3D models to images 

You can export 2D drawings or views of a 3D model in several standard image formats 

 
Expanded Close Corner Conditions in Sheet Metal 
Additional closed corner types allow more control for sheet metal flange creation 

 

 
Introduced in Alibre Design 8.x 

Ability to create 3D Sketches 

Sketch free-form 3D curves for use in a variety of modeling operations, including creating and routing piping or 
cables, or advanced sweeping and lofting. 

 
Enhanced Sweep and Loft Operations 
Supports multiple sweep paths or loft guide curves so you can create more complex sculpted shapes for consumer 
products and conceptual design. 

Importing of free-form surfaces 
Free-form Surfaces from applications such as Rhino can be imported and used to trim solid models or thickened into 
a solid for further editing. 

2D Drawing Enhancements 
2D Drawing enhancements include support for images in drawing templates, flexible handling of line styles and color 
definitions, and improved dimensions. 

User interface and productivity enhancements include: 
 Improved interaction with 2D sketches & sketch planes 

 Enhanced assembly constraints allowing grouping by component 
 Simplified multiple selection 
 Shaded reference planes for better visibility 

 
 
 

 



Introduced in Alibre Design 9.x 

Support for Design Configurations in drawings and bills of materials 
You can now use Design Configurations in Drawings and BOMs 
 

Improvements to spreadsheet-driven design  

You can now use Excel spreadsheets to support Design Configurations, multiple parameter selection etc.  
 

New tools to suppress/unsuppress assembly constraints 
You can now suppress and unsuppress assembly constraints and constituents in an assembly workspace  

Improved sheet metal functionality  
 Supports overlapping flanges, enabling the design of sheet metal enclosures with airtight edges  
 Expanded pallet includes punch patterns commonly used in sheet metal parts from turret punch press 

machines for cooling, weight reduction and attachment of fasteners and connectors  

 
2D drawing and sketching improvements 

 Improved import and export supports the latest versions of DXF and DWG files including AutoCAD 2006  
 Various drawing enhancements for aligning dimension text and support for new tolerance types  
 Addition of design parameters to BOM — This will be a great benefit for production where parameters can 

be used to define cut lengths and sent to nesting programs for determining material requirements for 
manufacturing  

 Usability improvements for layers  
 

New Pattern tool for creation of more complex user-defined patterns  
With the improved pattern tool, users now have a large selection of pre-defined pattern shapes and complete control 
over a wide variety of pattern attributes such as shape and pattern orientation and layout. Additional enhancements 
include:  

 More complex patterns can be created and then edited as a pattern  
 Controls on center-points and angles  
 Seven new parametric shapes including standard punch shapes  
 Six new pattern templates  

Alibre Motion 
Alibre Motion provides integrated motion simulation for Alibre Design Expert 9.1. Alibre Motion allows kinematic and 
dynamic motion simulation, including prescribed forces and torques, such as that generated by a motor or actuator in 
a real-world machine.  

3D PDF Publishing 
Model only publishing available in all packages. Alibre Design Professional and Expert also include the ability to create 
3D PDF files with animated exploded views and sequences of steps to help communicate design intent or document 

an assembly process. View 3D PDF files with the free Adobe Acrobat Reader 7.  

Drawings  
 Define multiple Dimension Styles and associate a dimension with a style  
 Select multiple dimensions to change dimension properties including style  
 Improved performance of detailing operations particularly when hidden lines are turned on  
 Reduce the memory footprint of drawings by optimizing the display segmentation of projected segments  



Assemblies  
 Improved performance while opening and editing assembly models, particularly those created using top-

down design  
 New option to turn off on-the-fly regeneration of related parts while editing a part in an assembly  
 New Apply button on the Insert Assembly Constraint dialog speeds up insertion of multiple assembly 

constraints  
 Enhancement to Exploded Views to input ‘Step’ information that can be published to 3D PDF (Alibre Design 

Professional and Expert)  

Sheet Metal  
 More intuitive determination of Flange and Tab lengths in relation to alignment type  

User Interface  
 Zoom now centers on the cursor instead of the center of the work area  
 Improved representation of Hole feature in sketch mode  

 New icons differentiate Cut and Boss features in the Design Explorer  
 Extrude and Revolve Part dialogs reappear in last open location  

 

 

Introduced in Alibre Design 10.x 

Direct Editing "Push/Pull" Tools  
As the name suggests, these new modeling tools allow you to edit or delete model features with a simple push or 
pull of the mouse, without having to worry about the design history or editing features or sketches. Grab a face and 
pull it up to increase its height, or click and remove fillets or nearly any model element. Make rapid alterations with 

ease, design conceptually, or edit imported models that come without a design history. Direct Editing is available in 
Alibre Design Professional and Expert - these tools include:  
 

 Push/Pull Face  
 Push/Pull Radius  
 Push/Pull Pocket or Boss  
 Remove Tool  

Fully Integrated Alibre CAM  
Take control of prototyping and production with Alibre CAM, the complete machining application now built into Alibre 
Design Expert. Set machining commands for commonly used manufacturing processes and ensure your model is built 
exactly to your specifications. Plus, you'll avoid the cost and confusion of having to add other third party CAM 
software to your product development.  

Fast 2D Views  
The new Fast View mode is designed for large or complex assemblies. Using Fast View mode, your model is brought 
into a 2D environment between 4 and 10 times faster than traditional view projection. You can dimension and detail 
your drawing and then convert it to a Precise View for the best print quality when you are ready. 

Topology Patterns  
New Topology Pattern tools go beyond the limitations of Feature Patterns. You can select portions of features or 
collections of faces to pattern them. Pattern design elements of imported geometry easily and quickly, without having 
to recreate any feature. 

 



Performance Enhancements 
 On average in v10, equivalent drawing workflows can be completed in half the time with only about 65% of 

the memory consumed in v9.2.  
 Drawing views update after a model edit without having to close and reopen drawings.  
 More responsive detailing.  

Productivity Enhancements 
 Double-click editing lets you click on features and edit them on the spot, instead of having to search 

through the Design Explorer.  
 Create multiple sketches on multiple planes without ever leaving sketch mode.  
 Auto-analyze sketch automatically notifies you of any potential sketch problems before you try to make a 

feature. Avoid having to re-trace modeling steps to locate a small error that got overlooked.  
 Auto Recovery ensures work is never lost due to unexpected interruptions. 

Core Software Improvements 
Migration to ACIS R16 kernel and latest versions of HLM, 2D/3D DCM.  

 

Introduced in Alibre Design 11.x 

Integrated PDM with the new Alibre Vault 
The new Alibre Vault by M-Files offers true, completely integrated, data and process management for all your files 
and workflows. The Alibre Vault completely integrates within Windows Explorer and Alibre Design, making it a 
recognizable interface for any user. File management is made easy by supporting all file types, security and 
collaboration options keep your files safe but accessible, and the many customizable search options save countless 
amounts of time from being spent on data hunting. 
 

Drag and Drop Constraint Mode 

A powerful new constraint application mode using visual feedback and real-time editing to apply constraints. Simply 
drag a part near another and the system previews applicable constraints on screen and allows easy changes and 
adjustments, like flip or rotate, before applying constraints.  

External Thread Representation 
Get industry standard 2D drawings of external threads without modeling the threads in3D. Just specify thread data 
while modeling simplified 3D geometry and this information is used to create the 2D drawing, lowering you modeling 
overhead and generating better drawings.  

Automatic Title Blocks 
2D Drawing Templates can be created which contain intelligent links that read data from part and assembly files. 
Title blocks and other drawing fields are automatically filled out, substantially reducing drawing time and errors. If 
the data in the source drawing or assembly file changes, these fields update automatically. 

 

Un-sectioning Parts in 2D 
You can now select the parts in 2D Section Views that won't be sectioned, providing full user control over which parts 
are sectioned and which are not.  

Enhanced View Rotation 
New view rotation mode that automatically uses the mouse location as the center of view rotation. If the mouse 
hovers over part geometry while view rotation is invoked, the mouse location becomes the center of view rotation, 
saving time by eliminating the need to zoom in or out to get the desired view orientation.  



Dimension Alignment 
2D dimensions now snap to each other to make precisely lining up dimensions fast and easy. Works with vertical, 
horizontal, and center alignments.  

Better Part Dragging with Assembly Constraints 
Dragging parts within assemblies while honoring constraints behaves more naturally. New constraint interpretation 
means it is no longer required to change between move and rotate tools to get the desired movement.  

Customizable and Easier to Use 
You can now customize the sizes and the colors of several items, including endpoint nodes and inferred sketch 
projection lines, making sketching easier and putting less strain on your eyes. Also, midpoint nodes are now inferred 
and appear automatically on line and arc segments by hovering the mouse.  

Further Improvements to 2D and Assembly Performance 
2D performance in Alibre Design 11 is substantially upgraded over previous versions. Fast Views, introduced in Alibre 
Design 10, are now on average 4 times faster during view projection than in previous versions. You wait seconds, not 
minutes, to see your drawings. 
 
Alibre Design 11 also offers huge speed improvements for nearly all common tasks in assemblies. Over 30 common 
tasks, such as editing parts or creating section views, have been made at least twice as fast on average. Combined, 
these represent a substantially more productive modeling and assembly experience.  

  

Introduced in Alibre Design 12.x 

Text Tool 
Description: Allows the automatic creation of text-based sketches for use in features 

Usage: Enter into a 2D sketch, press the text tool button, and enter the text, and format it. After applying the text, 
create a feature as normal. 
 

 



Color by Feature 
Description: Allows you to color parts of a model based on features 
Usage: Create a feature. In the Design Explorer, right click on the feature and select Feature Color. Select Specify 
Feature Color and define the color you would like. 

 

Set the Default Part Color 
Description: Allows you to select a default part color for all new parts 
Usage: Open a new part. Go to Edit > Color Properties. Choose a color, then click Make Default. 
 

 
 



Copy / Paste Stamper 
Description: Allows you to paste multiple copies of a copied item exactly where you want them. Works across 
workspaces. 
Usage: Copy something. Go to Edit > Paste Stamper. Begin clicking the mouse - the preview will show you where 
the item will be pasted before you click the mouse to apply.  
 

 

Customizable Toolbars 
Description: Create custom toolbars 
Usage: Right click on a toolbar. Select Customize Toolbars. Select New, name it, and then add the items you want.  
 

 
 

New Box Selection Methods 
Description: Dragging a box select from left to right selects only fully enclosed figures. Dragging from right to left 
selects fully and partially enclosed figures. 
Usage: See Description above 



 
 
 

 

Degree of Freedom Callouts - Sketching 
Description: When sketching, visual callouts can be turned on to notify you where you haven't defined the 
magnitude of figures (but not where you have not defined their position). Helps you to visually determine what 
remaining dimensions are required.  
Usage: Enter sketch mode and begin sketching. Turn on the DOF Callouts tool on the Sketching Options toolbar 
(new). You will see callouts on figures that do not have explicit magnitude dimensions. Click the callout to place a 
dimension without going into the dimension tool.  
 

 
 
 



Degree of Freedom Color Coding - Sketching 
Description: When sketching, figures can be color coded on the fly to visually represent whether they are fully 
defined, partially defined, or completely undefined. Use this to help you determine where a sketched profile requires 
more definition. 
 
Usage: Enter sketch mode and begin sketching. Turn on the DOF Colors tool on the Sketching Options toolbar 
(new). You will see your figures are now color coded per the legend at the bottom right of the screen.  
 

 
 

Real-time Dimensioning  
Description: When on, you can input dimensions for sketch figures while you are sketching to save time instead of 
sketching figures first and then dimensioning them later. 

 
Usage: Enter sketch mode. Turn on real-time dimensioning from the Sketching Options toolbar (new). While you 
sketch, you will see two boxes follow your cursor. To enter the boxes, press Tab. Switch between the boxes with Tab 
also. Tabbing out of a box also updates the preview to reflect the new change. Complete the figure by single clicking 
the mouse. A dimension is automatically applied. 
 
 

 
 



Quick Conversion Between Figures and Reference Figures 
Description: Previously only one figure could be converted at a time between being a reference figure and a regular 
figure. Now, you can convert multiple figures simultaneously. 
 
Usage: Select the figures you want to convert. They will turn blue as shown below. On the Sketch Options toolbar, 
select the appropriate button for converting the figures to Regular or Reference figures. The example below shows 
converting regular figures to reference figures. 
 

 

2D Constraint and Snapping Options 
Description: You can now set preferences for which constraints Alibre Design automatically places and polar 
snapping options. 
 
Usage: In a part workspace, select Sketch > Snap and Constraint Settings. Select or unselect which constraints you 
would like to be placed as you sketch. Set options for polar snapping as well.  
 
Note: Regardless of the options you define for constraint snapping, Alibre Design will always infer them. If a 
checkbox is off, Alibre Design simply will not place the constraint. You will get a visual indication that the constraint is 
being inferred, but the preview of the constraint will be light gray instead of the normal color. You can override the 
non-placement of a constraint by holding Shift before you finish the figure. 
 

 



Dimension Box (OK, Cancel) 
Description: You can now confirm or cancel dimensions without using the keyboard. 
Usage: When a dimension box is open, press the check mark or the cancel button. 
 

 
 

Mirror Over Axis (sketching) 
Description: You can now mirror figures directly over an axis without creating a reference line first 
Usage: Sketch some figures. Open the Sketch Mirror tool, select an Axis for the Mirror Axis, and press OK. 

Ability to Edit 3D Section Views 
Description: You can now change the properties of a section view instead of being forced to create a new one 
Usage: Right click on an existing section view in the Design Explorer. Select Edit. 

 

 

 

Animated View Transitions 
Description: When turned on, any time the view changes (going into sketch mode, reorienting on extrusions, and 
selecting view orientation buttons) the view transition will be gently animated instead of immediately snapping. 
Usage: This function works in the background. No specific usage is required. 

 

Default Color Scheme 
Description: A new default color scheme has been created.  



Usage: If you would like to use the default color scheme, and have previously defined a custom color scheme, 

simply select it from the list in the Color Schemes dialog. If you have never installed Alibre Design before, this 
scheme will be the default. 

 

Multiple Lights in 3D Workspaces 
Description: The model will never be black (overly shaded) any more. Up to 3 lights can be used, available in Tools 
> Options. The single light option has been tweaked to also prevent black areas. The model looks much nicer as 
well. 
Usage: Set the light number to 1, 2, or 3 in Tools > Options. 
 

 

Combined Move/Rotate Tools (Assembly) 
Description: The previous Move and Rotate tools have been combined into a single tool 
Usage: Select the Toggle Triad tool on the Assembly Modeling toolbar. Click on a part and the Triad pops up. Select 
portions of the triad based on what you want to do. You can perform several operations in a row. 

 

 

Reworked Assembly Pattern Dialogs 
Description: The linear and circular assembly pattern dialogs have been changed to be more consistent with 
pattern dialogs elsewhere in the product. 
Usage: N/A 



 

Contour Flange (Sheet Metal) 
Description: You can now automatically create a tab and multiple flanges using a single profile sketch 
Usage: In a sheet metal workspace, create a profile sketch. The sketch must contain at least one line (since there 
must be at least one tab), and can only contain lines and tangent arcs. After the sketch is created, select the Contour 
Flange tool and input the variables. You can also override individual bend radii after the Contour Flange has been 
created. Note that tangent arcs must have a tangent constraint applied. This would not be automatic, for example, if 
you projected a sketch from a solid that had a tangent arc. 
 

 
 

Lofted Flange (Sheet Metal) 
Description: You can now create lofted flanges between: circles/ellipses and squares/rectangles using a wizard  
Usage: In a sheet metal workspace, click the Lofted Flange tool. Determine which transition type you want, fill in the 
values, and press OK. 

 

 

Freeform Table Creation (2D Drawings) 
Description: You can now add tables to 2D drawings in a quick and efficient manner 
Usage: In a 2D drawing, select the General Table tool. Input the initial options for row and column count. Then, 
click on the table and click a field to edit it. You can format the text in the cells, drag the rows/columns around, 
merge cells, etc. 
 



 

 

Shaded and Visible Edges Mode Now Default 
Description: Previously the Shaded and Visible Edges display mode was not the default due to some performance 
issues on complex assemblies. This issue has been corrected and there is now almost no difference between Shaded 
and Shaded and Visible Edges performance.  
Usage: N/A 

 

 

Icon Previews for Parts/Assemblies/Drawings in Windows/Vault 
Description: Windows Explorer and the Alibre Vault will show icon previews for files saved in v12. 
Usage: Ensure that your Windows folder settings are set to display thumbnail previews.  
 

 



Substantial View Performance Increase for Large Assemblies 
Description: View interaction (rotate/pan/etc) has been substantially improved for large assemblies. Now, only the 
visible portion of the model is rendered – if you are zoomed in to a subsection of a large assembly, the subsection 
will have the same response as if you were viewing a single part.  
Usage: N/A 
 

Substantial 2D Drawing Import Performance Improvement 
Description: After importing DWG/DXF files, when you tried to edit the sheet on a large or very data intensive 
import some people experienced extreme performance degradation or crashes. This issue has been fixed. The most 
notable visual difference will be that nodes (endpoints) of figures are no longer all visible at once – they become 
visible when the mouse is hovered over a figure, but only for that figure. 
Usage: N/A
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